QBWC 1012 & 1048: Authentication failed
Incident Report for Connex ECommerce
Postmortem

Introduction

Connex encrypts information that it sends to and from QuickBooks. Versions or QuickBooks 2013 and older use SSL V3 and TLS 1.0, which are outdated methods of encrypting information. For security reasons, we disabled SSLv3 and TLS 1.0 as of October 25th, 2019. In addition, we upgraded to the latest version of TLS 1.2 as recommended by our hosting company, when we upgraded our server infrastructure in preparation for the 2019 holiday shopping season (you can read the announcement here).

As a result, Intuit Web Connector version 2.1.0.30 - required for use of QuickBooks Point of Sale - is no longer supported. Furthermore, Connex is no longer compatible with versions of Windows that do not have TLS 1.2 enabled.

Is there another error related to this issue?

You may also see this message:

Authentication failed due to following error message.

The underlying connection was closed: An unexpected error occurred on a send.

Who experiences these issues?

Customers using QuickBooks 2015 and older will experience these problems. Users on Windows 7, Windows Server 2012 and Windows Server 2016 could experience this issue. TLS 1.2 is disabled on operating systems older than Windows 10 and Windows Server 2018.

What is the difference between older versions of SSLv3 and TLS 1.0?

Please read this guide.

How do I resolve this error?

These instructions are a work in progress and we will have final instructions soon. You must instruct QuickBooks that TLS 1.2 is enabled.

On our test development Windows 10, we downloaded IIS Crypto. Here is how it appears. Here is how our registry appears. You can access the registry by entering regedit in the Windows search. The path is here:

Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.0

Install .NET 4.61 on your computer. Once complete, reboot and try the web connector again.

Is there a way to create the keys using regedit?

The guide below will create the proper keys. Please note once changes are made, you must reboot.

Change Registry Keys

  1. Download this file.
  2. Unzip it.
  3. Right click the file and select merge.
  4. If prompted, click OK.
  5. Reboot your machine.
  6. Run your web connector.

Change Internet Options TLS

Here are the steps:

  1. In Windows search, enter Internet Explorer.
  2. Open the browser.
  3. On the right, click the gear.
  4. Click internet options.
  5. Click the advanced tab.
  6. Scroll to the bottom.
  7. Enable TLS 1.2:
  8. Reboot your PC and run your web connector.

Change Web Connector Config File

Here are the steps:

  1. Unzip this file.
  2. Copy it here: C:\Program Files (x86)\Common Files\Intuit\QuickBooks\QBWebConnector\QBWebconnector.exe.config
  3. Click OK to overwrite.
  4. Reboot your computer.
  5. Run the web connector.

How do I verify I am using TLS 1.2?

Here are the steps:

  1. Download Fiddler.
  2. Install Fiddler.
  3. Open Fiddler.
  4. In Fiddler, go to tools and click options.
  5. Click HTTPS.
  6. Uncheck decrypt HTTPs traffic:
  7. Run the web connector.
  8. Look for connexforquickbooks.com.
  9. Click textview.
  10. Verify TLS 1.2
Posted Nov 19, 2019 - 12:40 EST

Resolved
Please upgrade your OS to Windows 10 or Windows Server 2018. If you cannot upgrade, please use RightNetworks to host your company file. We are unable to support TLS 1.0 and older operating systems at this time.
Posted Oct 29, 2019 - 13:58 EDT
Update
Having isolated the issue, we have devised a means to remedy for Windows 7, Windows 7 Professional, Windows Server 2012, and Windows Server 2016 users.

To remedy this issue, please review this guide. Deploying these steps has resolved the issue for some of our customers.
- https://help.syncwithconnex.com/hc/en-us/articles/360035226432-Quickbooks-Web-Connector-could-not-verify-the-web-application-server-certificate-


Note that we we continue to monitor and search for a permanent solution that doesn't involve making changes to your operating system. We will continue to provide updates as they become available.
Posted Oct 29, 2019 - 10:55 EDT
Update
We've isolated the problem to customers running Windows 7.

This means that there is not an issue with the Web Connector itself nor the version of QuickBooks being run.

We continue to monitor and will update with next steps as they become available.
Posted Oct 28, 2019 - 17:50 EDT
Update
We're aware that QuickBooks POS customers are likewise affected and that upgrading to the latest version may not be an option.

We are continuing to monitor the situation and working aggressively with our technology partners to find a permanent solution.

The issue affects users on Windows 7 and Windows Server 2012. Upgrading to the latest OS has helped some customers.
Posted Oct 28, 2019 - 14:57 EDT
Monitoring
We are aware of an issue with the QuickBooks Web Connector in which a segment of customer have reported "QBWC1012" and "QBWC1048" Authentication Failed via the Web Connector error message below.

This means that the version of QuickBooks you are currently running is not compatible with Connex Desktop due to a specific security TLS protocol.

------------
"Version:
Not provided by service

Message:
Authentication failed

Description:
QBWC1012: Authentication failed due to following error message.

The underlying connection was closed: An unexpected error occurred on a send. See QWCLog for more details. Remember to turn logging on."
Posted Oct 28, 2019 - 13:10 EDT
This incident affected: Connex for QuickBooks - Desktop Users.